F.A.O. Anyone with Car


Aza
 Share

Recommended Posts

I've got a ford fiesta, zetec 16v.

Recently ive come under the suspision that there has been a prob with my oil. Ive been changing it every 3weeks or so, which is not healthy!

i looked underneath the car and noticed that it appears to be "bleeding". Its not leaking dramatically i.e. not patches on the floor, but underneath it covered in oil.

Any ideas (apart from trying to get it sorted out ASAP)?

Link to comment
Share on other sites

Is it leaking from the sump? It might just well be the sump bolt not tight enouhg, u should not be changing ure oil so often, oil chanegs should only occur every 5,000 miles or so!!

Check hwere its leaking from and let us know!

Link to comment
Share on other sites

well, if u'd had it done at a garage u could just take ure car back and get them to sort it out for free!

Right, u need to check ure sump and filter, did u change the filter when u changed the oil?

wipe away the oil around the filter seal and around the sump bolt (the bolt under the engine where u bleed the oil from when changing it).

I reckon it may be your sump bolt is not tight enough or your filter is not tight enough!

Link to comment
Share on other sites

yeah, right, look for what looks likea tank in the niddle, at the bottom on the engine, its called the sump where all the oil from the engine collects bfore been pumped back around the engine. There will be a small bolt bout the size of a 1p sumwhere on the bottom, check for oil aroundit and if theres oil thats where its leaking from (most probable i'd say).

Link to comment
Share on other sites

Why don't you pop into Halfords or any car shop that sells car manuals and have a look in the one for your make of car and model. At least it should give you some idea of where to find the oil sump etc. Can you remember how long ago it was when you first noticed you were using more oil? Is it since you changed the oil filter? Seems Bjorn knows what he is talking about. Hope it turns out to be just a loose bolt.

Link to comment
Share on other sites

Apparently it has something to do with the "oil pressure switch, which is wear & tear. Set back bout £60 & also having a new CAM belt in. Thus = £100!

Looks like Ill have to wait until Nov time when its my BDAY to get me decks :oops: :oops: :oops:

Link to comment
Share on other sites

I'm not absolutely sure about oil pressure switch and I guess it depends on your car model, but I would have thought that'd cost about £30. And a cam belt is just essentially band of rubber isn't it? Surely that's a about a fiver! :?:

Obviously I could be way out of my depth here and be totally wrong, but...

Link to comment
Share on other sites

But had a new tyre put on there aswell, which was £22.

Yeah that always happens! Ages ago I went in to get a chip in the windscreen patched up - when they'd finished and I was just about to drive away, there was the "hey mate, whilst you're here, you ought to think about changing that tyre..." :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share